04/02/16 Mikrotik: Utilizando o Zentyal como proxy externo

Ainda considerando que você possui um servidor Mikrotik como Firewall da sua rede e que agora quer integrar um proxy externo (Zentyal + Squid) em modo transparente então basta criar um redirecionamento dst-nat:

/ip firewall nat
add action=dst-nat chain=dstnat dst-port=80 in-interface=LAN protocol=tcp src-address=192.168.0.0/24 to-addresses=10.10.1.105 to-ports=3128

No exemplo acima, 192.168.0.0/24 é sua rede local e 10.10.1.105 é o endereço do servidor proxy. Um detalhe importante é que o Zentyal, por padrão, irá bloquear o acesso dos computadores da sua rede, para finalizar a configuração você terá que adicionar uma regra no Firewall permitindo o acesso:

Firewal > Packet Filter > External networks to Zentyal

Fica aí a dica!

29/01/16 Mikrotik: Redirecionamento Externo com DST-NAT

O cenário: você instalou um servidor Mikrotik como Firewall da sua rede e agora quer que conexões externas para o servidor (Interface WAN, Ex: IP 186.195.184.12) sejam redirecionadas para um servidor Web interno (Ex: 10.10.1.102).

Eis a configuração a ser feita:

/ip firewall nat
add action=dst-nat chain=dstnat dst-address=186.195.184.12 dst-port=80 protocol=tcp to-addresses=10.10.1.102 to-ports=80

Fica aí a dica!

29/01/16 Mint + Cinnamon Debugger

Uma coisa que vinha me incomodando há tempos mas que eu nunca havia parado pra resolver – até hoje – foi o fato de, no Mint, ao pressionar o atalho WINKEY + L a tela não ser bloqueada mas sim ser executado o Melange – Cinnamon Debugger.

Pra quem é ou foi usuário de Windows por muito tempo isso é um problema. Para resolver, basta modificar a tecla de atalho, e eis o caminho:

Preferências > Teclado > Atalhos de Teclado > Geral > Soluções de Problemas > Ativar Lupa

Fica aí a dica!

22/01/16 phpMyAdmin – Como alterar o idioma

Provavelmente você percebeu que ao instalar o phpMyAdmin a interface é configurada automaticamente para o idioma do host, porém caso queira modificá-lo o procedimento é bem simples, basta editar o arquivo config.inc.php:

sudo nano /etc/phpmyadmin/config.inc.php

E inserir no final do arquivo a entrada:

$cfg['Lang'] = 'en';

No exemplo, o idioma será alterado para o inglês.

Fica aí a dica!

21/01/16 Sublime Text 3: Toogle Comment

Instalou o Sublime Text 3 e percebeu que que o atalho para inserir comentários (Edit > Comment) não está funcionando? Eis a solução:

Vá em Preferences > Key Bindings – User e insira o seguinte código:

[
{ "keys": ["ctrl+keypad_divide"], "command": "toggle_comment", "args": { "block": false } },
{ "keys": ["ctrl+shift+keypad_divide"], "command": "toggle_comment", "args": { "block": true } },
]

Fica aí a dica!

20/01/16 Sublime Text 3: Instalação e Plugins Adicionais

E eis que finalmente decidi migrar do Notepad++ para o Sublime Text.

Se você, assim como eu, também está iniciando com o aplicativo, já instalou o Package Control e agora está procurando por alguns plugins úteis, eis a minha lista:

  • Emmet
  • AutoFileName
  • Sublimerge (será útil: Ctrl + Alt + D)

Alguns plugins específicos para determinadas linguagens:

  • AngularJS-sublime-package
  • VueSyntaxHighlight

Lembre-se que para instalar os plugins basta abrir o Gerenciador de Pacotes (Ctrl + Shift + P). Uma configuração interessante de ser ativada é a exibição do encoding do arquivo na barra de status, nesse caso:

Vá em Preferences > Settings – User e insira o seguinte código:

"show_encoding" : true

“Bônus”: Material Theme + Material Theme AppBar + Settings – User:

{
  "color_scheme": "Packages/Material Theme/schemes/Material-Theme.tmTheme",
  "theme": "Material-Theme.sublime-theme",
  "material_theme_tree_headings" : true,
  "show_encoding" : true,
  "tab_size": 2,	
}

Fica aí a dica!

17/01/16 Mikrotik: Atualizando o RouterOS e o Firmware

Tome nota: para atualizar o RouterOS vá em: Quick Set > Check For Updates > Download & Upgrade. Já para atualizar o Firmware vá em: System > Routerboard > Upgrade e em seguida reinicie o dispositivo.

Fica aí a dica!

15/01/16 iptables – bloqueando conexão entre hosts

Dica rápida pra quem precisa bloquear a conexão entre hosts de uma mesma rede através do iptables: o bloqueio pode ser feito na tabela mangle, na chain PREROUTING, exemplo:

iptables -t mangle -I PREROUTING -s 192.168.0.249 -d 192.168.0.101 -j DROP

Fica aí a dica!

15/01/16 Firefox + Kaspersky + HTTPS: Esta conexão não é confiável

Se você instalou o Kaspersky e, ao tentar acessar algum site no Firefox através de uma conexão HTTPS, recebeu uma janela de aviso de “Esta conexão não é confiável” eis a solução:

Na barra de endereços do Firefox digite:

about:preferences#advanced

Em seguida siga esse caminho:

  • Clique no botão “Ver certificados”
  • Selecione a aba “Autoridades” e clique no botão Importar…
  • Navegue até a pasta C:\ProgramData\Kaspersky Lab\AVP15.0.2\Data\Cert e selecione o arquivo (fake)Kaspersky Anti-Virus Personal Root Certificate
  • Na janela “Recebendo o certificado” marque os 3 checboxes e clique em OK!

Pronto!

13/12/15 VDI, VMDK, VHD, HDD, QED e QCOW

Pra quem não conhece, essa sopa de letrinhas refere-se aos diversos formatos de sistemas de arquivos utilizados em máquinas virtuais, no caso, todas suportadas pelo VirtualBox.

Se você sabe ler inglês, dá uma olhada nesse link.

Fica aí a dica!

10/12/15 Completam-se ou completa-se alguns meses?

Eis que surgiu a dúvida! E:

Em indicações de horas, datas, tempo, distância – a concordância será feita com a expressão numérica!

Logo, o correto é: completam-se nove meses desde que eu fiz aquela viagem! Ou então, completa-se um ano que eu a conheci.

Fica aí a dica!

08/12/15 Mint: ACPI PCC probe failed

Eis que logo após instalar o driver de vídeo da NVIDIA no Mint – e reiniciar o computador – me deparei com o seguinte erro: ACPI PCC probe failed

A solução: Fiz login no sistema através das opções avançadas do GRUB, abri o arquivo /etc/default/grub pelo Terminal e em seguida adicionei o parâmetro “nomodeset” na opção GRUB_CMDLINE_LINUX_DEFAULT, ficando a linha assim:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Por fim foi preciso aplicar a modificação – e reiniciar o computador:

$ sudo update-grub

Fica aí a dica!